What is the output of "show mod" on your switch?

Why no LACP? it is supposed to improve the failover capability.

It is simple to setup:
# ifconfig e0a flowcontrol full #not needed
# ifconfig e0b flowcontrol full #not needed
vif create lacp -b mac  vif17 e0a e0b
# vif favor e0a not used in multi or lacp
ifconfig vif17 `hostname`-vif17 up netmask 255.255.255.0 broadcast xxx.xx.xxx.255 partner vif18
route add default xxx.xx.xxx.x 1
routed on


On the switch:
interface GigabitEthernet6/7
description xxx17[e0a]
switchport
switchport access vlan xxx
switchport mode access
no ip address
flowcontrol receive on
flowcontrol send on
spanning-tree portfast
channel-group 99 mode active

(the active in the last line defines LACP, setting it to on is straight up etherchannel, i.e. pre 7.2 code)

And also on the switch:
interface Port-channel 99
description PortChannel for vif17
switchport
switchport access vlan xxx
switchport mode access
no ip address
flowcontrol receive on
flowcontrol send on
spanning-tree portfast


On 6/13/07, Todd C. Merrill <tmerrill@mathworks.com > wrote:

I'll try to answer most of the questions posed so far...

For the filer involved in the latest incident:


> what is the contents of /etc/rc pertaining to the network?


ifconfig e0a flowcontrol full
ifconfig e0b flowcontrol full
vif create single vif17 e0a e0b
vif favor e0a
ifconfig vif17 `hostname`-vif17 up netmask 255.255.255.0 broadcast xxx.xx.xxx.255 partner vif18
route add default xxx.xx.xxx.x 1
routed on



> What about the stanza(s) from the switch about the connected interface?

interface GigabitEthernet6/7
description xxx17[e0a]
switchport
switchport access vlan xxx
switchport mode access
no ip address
flowcontrol receive on
flowcontrol send on
spanning-tree portfast


> I use LACP for my vifs (FAS980/R200 and used to on a FAS6070 until it was changed to GX).

Our network guys told me we do not use LACP.


> Are the VIFs in single mode or multi mode?  Maybe try going the other
> way unless you have bandwidth constraints.  We run single here because
> the interfaces are plugging into different switches.

Single mode (see config info above).  We do that because we don't need
the bandwidth; we often sniff the port; and we only require the redundancy.



> Wondering if the vifs have been  created out of multiple interfaces on
> the same or across multiple switches?

Same switch, different blades.



> What does the configuration look like? How many interfaces on the
> switch? How many switches? Vlans? Etc....  Are there any other
> interfaces configured on different subnets/networks? Do they become
> unresponsive also?

Switch interface config shown above.  Switch has 4x48 interfaces.
One switch involved.  40+ VLANs on the switch in total.  None of
the other subnets/networks experience the unresponsiveness.  And,
neither do the other five 6070's on this same switch on the same
VLAN on the same subnet.



> What kind of switches are you using, and what code rev?

Cisco 6506.

#sh version
Cisco Internetwork Operating System Software
IOS (tm) s3223_rp Software (s3223_rp-IPBASEK9-M), Version 12.2(18)SXF, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Fri 09-Sep-05 21:36 by ccai
Image text-base: 0x40101040, data-base: 0x42CC0000

ROM: System Bootstrap, Version 12.2(17r)SX3, RELEASE SOFTWARE (fc1)
BOOTLDR: s3223_rp Software (s3223_rp-IPBASEK9-M), Version 12.2(18)SXF, RELEASE SOFTWARE (fc1)


> My first focus would be on the LAN switch fabric- making sure that
> spanning tree is functioning correctly; if you are using VLANs, that
> your ISL trunks are correct; this smells like some sort of broadcast
> storm/loop.   You're describing a situation where 'all of a sudden' you
> get a 100% ping loss and then flapping up and down on the network, that
> really sounds like a switching issue- as if the spanning tree is
> converging because something ELSE got added to the segment.  Do you have
> Portfast set on the ports the netapp is connected to?  How many
> interfaces do you have?

No other devices on the same switch, on the same VLAN, on the same subnet experience
a similar loss of connectivity.  :-\

Network guys say the logs show no spanning tree activity during or just prior
to the incident.



> OR- perhaps someone is introducing a device with the same IP as the
> netapp?

Also no duplicate IP entries in the logs either.




Thanks for the ideas...keep them comin'...


        Until next time...

The MathWorks, Inc.                             508-647-7000 x7792
3 Apple Hill Drive, Natick, MA 01760-2098       508-647-7001 FAX
tmerrill@mathworks.com                          http://www.mathworks.com
---




--
--tmac

RedHat Certified Engineer